WordPress - 動作環境

動作環境

WordPress の動作要件は以下のとおりです。

  • Webサーバ:Apache、または Nginx(推奨)
  • PHP:バージョン 7.3 以上
  • データベース:MySQL 5.6 以上、または MariaDB 10.1 以上
  • HTTPS をサポートしていること

WordPress は、PHP と MySQL が動くサーバであれば、どのようなサーバでも動作しますが、公式には Apache、または Nginx が推奨されています。また、PHP や MySQL は、上記のバージョンよりも古いバージョンでも動作する場合もありますが、公式にはサポートが切れており、サイトを脆弱性にさらす危険性があります。

一般的なレンタルサーバ会社(さくらインターネット、XSERVER など)は、WordPress をインストールするための要件を満たしています。また、WordPress のインストール自体も、コントロールパネルから簡単にインストールできるようになっているため、特に専門知識を必要としません。詳細は、インストールのページで解説します。

関連記事